您现在的位置:首页>建站学院>使用教程

如何配置支持云模块运行的Zend环境?

为了保障云模块系统安全,采用了ZendGuardLoader进行加密;【注意:模板永久不加密,用户可自由修改】

那么如何配置支持云模块运行的Zend环境呢?
虚拟主机99%都支持zend环境,PHPstudy、Wamp等集成环境也默认支持,因此无需配置;本教程主要针对自配环境用户。

1、下载与PHP版本对应的ZendGuardLoader组件,这里以PHP5.4为例,则对应下载【ZendGuardLoader-PHP-5.4-Windows-x86】(点击可下载)这个组件 或者 进入【zendGuard官方下载】。

2、得到ZendGuardLoader-70429-PHP-5.4-Windows-x86.Zip压缩包,解压后得到“ZendLoader.dll”文件。如图径:


3、将“ZendLoader.dll”复制到对应PHP安装目录(如下图)的文件夹下(这里“123”文件夹是为了方便阅读新建的)。

      


4、找到PHP5.4的安装位置下面的“php.ini”文件:如图路径:


5、用记事本或编辑工具打开,在如下图位置处写入对应路径“zend_extension=D://phpStudy/php54n/ext/123/ZendLoader.dll”,保存退出,重启PHP环境即可。



特别说明:本地电脑、云服务器、VPS等配置一样,图中PHPstudy字样为示范,事实上PHPstudy无需配置。